summaryrefslogtreecommitdiffstats
path: root/avahi-python/avahi-discover/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-python/avahi-discover/Makefile.am')
-rw-r--r--avahi-python/avahi-discover/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/avahi-python/avahi-discover/Makefile.am b/avahi-python/avahi-discover/Makefile.am
index c1d6cab..e9c5583 100644
--- a/avahi-python/avahi-discover/Makefile.am
+++ b/avahi-python/avahi-discover/Makefile.am
@@ -23,7 +23,7 @@ EXTRA_DIST = \
__init__.py \
SimpleGladeApp.py \
avahi-discover.in \
- avahi-discover.desktop.in
+ avahi-discover.desktop.in.in
if HAVE_PYTHON
if HAVE_PYTHON_DBUS
@@ -41,6 +41,7 @@ if HAVE_GDBM
pythonscripts += \
avahi-discover
desktop_DATA += avahi-discover.desktop
+@INTLTOOL_DESKTOP_RULE@
avahi_discover_PYTHON += __init__.py SimpleGladeApp.py
endif
@@ -48,14 +49,17 @@ if HAVE_DBM
pythonscripts += \
avahi-discover
desktop_DATA += avahi-discover.desktop
+@INTLTOOL_DESKTOP_RULE@
avahi_discover_PYTHON += __init__.py SimpleGladeApp.py
endif
-avahi-discover.desktop: avahi-discover.desktop.in
+avahi-discover.desktop.in: avahi-discover.desktop.in.in
sed -e 's,@bindir\@,$(bindir),g' $< > $@
avahi-discover: avahi-discover.in
sed -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@GETTEXT_PACKAGE\@,"$(GETTEXT_PACKAGE)",g' \
+ -e 's,@LOCALEDIR\@,"$(datadir)/locale",g' \
-e 's,@interfacesdir\@,$(interfacesdir),g' $< > $@
chmod +x $@