summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-01-14 22:45:22 +0000
committerLennart Poettering <lennart@poettering.net>2004-01-14 22:45:22 +0000
commitdcc8faf7a28745d566f662969c09e9c41ebd0408 (patch)
tree6e24b0baca370a77d3ab134be903b34b18e0b040 /configure.ac
parent2187fc7c62ffad7cb514d061899d57cfd95438dc (diff)
add man page
git-svn-id: file:///home/lennart/svn/public/bidilink/trunk@8 9cde1c1d-e4d0-0310-8a68-bf217395ea82
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ad456aa..4803a9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,18 @@ AC_CHECK_FUNCS([dup2 gethostbyname memset select socket strcspn strdup strerror]
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h termios.h unistd.h])
+# Where to place the UUCP lock directory
+AC_ARG_WITH(lockdir, AS_HELP_STRING(--with-lockdir=DIR,The UUCP lock directory (/var/lock)))
+
+if test "x$with_lockdir" = xyes -o "x$with_lockdir" = xno -o "x$with_lockdir" = x ; then
+ LOCKDIR="/var/lock"
+else
+ LOCKDIR="$with_lockdir"
+fi
+
+AC_MSG_NOTICE([*** UUCP lock directory is $LOCKDIR ***])
+AC_SUBST(LOCKDIR)
+
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
AS_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),
@@ -98,5 +110,5 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
-AC_CONFIG_FILES([src/Makefile Makefile doc/Makefile doc/README.html]) # man/Makefile ])
+AC_CONFIG_FILES([src/Makefile Makefile doc/Makefile doc/README.html man/Makefile])
AC_OUTPUT