summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-01-14 22:45:22 +0000
committerLennart Poettering <lennart@poettering.net>2004-01-14 22:45:22 +0000
commitdcc8faf7a28745d566f662969c09e9c41ebd0408 (patch)
tree6e24b0baca370a77d3ab134be903b34b18e0b040 /man/Makefile.am
parent2187fc7c62ffad7cb514d061899d57cfd95438dc (diff)
add man page
git-svn-id: file:///home/lennart/svn/public/bidilink/trunk@8 9cde1c1d-e4d0-0310-8a68-bf217395ea82
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..ede7107
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,37 @@
+# $Id$
+
+# This file is part of bidilink.
+#
+# bidilink is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# bidilink is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with bidilink; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+man_MANS = bidilink.1
+
+noinst_DATA = bidilink.1.xml
+
+EXTRA_DIST = $(man_MANS) bidilink.1.xml.in xmltoman.css xmltoman.xsl xmltoman.dtd
+
+CLEANFILES = bidilink.1.xml
+
+bidilink.1.xml: bidilink.1.xml.in Makefile
+ sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+if USE_XMLTOMAN
+
+CLEANFILES += $(man_MANS)
+
+bidilink.1: bidilink.1.xml Makefile
+ xmltoman $< > $@
+
+endif