summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2004-07-21 13:30:34 +0000
committerMarcel Holtmann <marcel@holtmann.org>2004-07-21 13:30:34 +0000
commit3429ef600fcef09e96408f8b476ead6cb519cf83 (patch)
tree9c053b36808b3ab6a402133bb55c6e2e444e0d44 /Makefile.am
parente9eeb41ebdc975e33d992bfa190fd84399550e34 (diff)
Make use of MAINTAINERCLEANFILES
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c4fc53e6..34e8e0a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,11 +2,18 @@
# $Id$
#
-SUBDIRS := include src
-
-DISTCLEANFILES = conftest.c conftest bluez.pc
+SUBDIRS = include src
EXTRA_DIST = ChangeLog libs.spec
+DISTCLEANFILES = bluez.pc
+
+MAINTAINERCLEANFILES = Makefile.in \
+ aclocal.m4 configure config.h.in config.sub config.guess \
+ ltmain.sh missing install-sh mkinstalldirs
+
install-data-local: bluez.pc
- $(INSTALL) -D -m 644 $(top_builddir)/bluez.pc $(DESTDIR)$(libdir)/pkgconfig/bluez.pc
+ $(INSTALL) -D -m 644 $(top_builddir)/$< $(DESTDIR)$(libdir)/pkgconfig/$<
+
+uninstall-local: bluez.pc
+ @rm -f $(DESTDIR)$(libdir)/pkgconfig/$<