summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2004-07-28 07:09:49 +0000
committerMarcel Holtmann <marcel@holtmann.org>2004-07-28 07:09:49 +0000
commit510555837596e01a69cdcc40a7ffdafeeabd80cd (patch)
treef4b2541565d326b20809a55d34294c4f0514e4ef /Makefile.am
parented7c684d772592204d02a5d04bb1f68746cf91e2 (diff)
Use simpler way to install bluez.pc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 538873b1..dde46889 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,10 @@
SUBDIRS = include src
+pkgconfigdir = $(libdir)/pkgconfig
+
+pkgconfig_DATA = bluez.pc
+
EXTRA_DIST = libs.spec
DISTCLEANFILES = bluez.pc
@@ -11,9 +15,3 @@ DISTCLEANFILES = bluez.pc
MAINTAINERCLEANFILES = Makefile.in \
aclocal.m4 configure config.h.in config.sub config.guess \
ltmain.sh missing install-sh mkinstalldirs
-
-install-data-local: bluez.pc
- $(INSTALL) -D -m 644 $(top_builddir)/$< $(DESTDIR)$(libdir)/pkgconfig/$<
-
-uninstall-local: bluez.pc
- @rm -f $(DESTDIR)$(libdir)/pkgconfig/$<