summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-05-08 13:27:42 +0000
committerMarcel Holtmann <marcel@holtmann.org>2008-05-08 13:27:42 +0000
commit1e3561c600a08b5a5dc45b405fe1ecc30df4f270 (patch)
tree49cbd5c9db7e5889ae579b013f8a512ead20f6d3 /common/Makefile.am
parentca1711891647c07d70fbcce29ef7e7576e45c016 (diff)
Remove HAL support helpers
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index c231319b..7dac6b6a 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,10 +1,4 @@
-if HAL
-hal_sources = hal-libhal.c
-else
-hal_sources = hal-dummy.c
-endif
-
if INOTIFY
notify_sources = notify-inotify.c
else
@@ -16,8 +10,8 @@ noinst_LIBRARIES = libhelper.a
libhelper_a_SOURCES = oui.h oui.c dbus.h dbus.c \
textfile.h textfile.c logging.h logging.c \
dbus-helper.h dbus-helper.c error.h error.c \
- glib-helper.h glib-helper.c sdp-xml.h sdp-xml.c sdp-glib.c \
- hal.h $(hal_sources) notify.h $(notify_sources)
+ glib-helper.h glib-helper.c notify.h $(notify_sources) \
+ sdp-xml.h sdp-xml.c sdp-glib.c
noinst_PROGRAMS = test_textfile
@@ -25,7 +19,6 @@ test_textfile_LDADD = libhelper.a
AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@
-EXTRA_DIST = ppoll.h uinput.h hal-dummy.c hal-libhal.c \
- notify-dummy.c notify-inotify.c
+EXTRA_DIST = ppoll.h uinput.h notify-dummy.c notify-inotify.c
MAINTAINERCLEANFILES = Makefile.in