summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-03-20 14:48:00 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-03-20 14:48:00 +0000
commit6e2ea33ba70a7d6b6ffa614a8fe57fe7662b7c70 (patch)
tree9f5e9518021b69891a65f8bf25f8ad1768a2b8b7 /common/Makefile.am
parentfaaa78e8988895aecf12f5ef113d3683c7986999 (diff)
Create a common HAL abstraction layer
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 77a77322..a2e50354 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -9,6 +9,12 @@ sdp_sources = sdp-dummy.c
endif
endif
+if HAL
+hal_sources = hal-libhal.c
+else
+hal_sources = hal-dummy.c
+endif
+
if INOTIFY
notify_sources = notify-inotify.c
else
@@ -21,7 +27,7 @@ libhelper_a_SOURCES = oui.h oui.c dbus.h dbus.c \
textfile.h textfile.c logging.h logging.c \
dbus-helper.h dbus-helper.c \
sdp-xml.h sdp-xml.c $(sdp_sources) \
- notify.h $(notify_sources)
+ hal.h $(hal_sources) notify.h $(notify_sources)
noinst_PROGRAMS = test_textfile
@@ -29,7 +35,7 @@ test_textfile_LDADD = libhelper.a
AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@
-EXTRA_DIST = ppoll.h uinput.h \
+EXTRA_DIST = ppoll.h uinput.h hal-dummy.c hal-libhal.c \
notify-dummy.c notify-inotify.c \
sdp-dummy.c sdp-expat.c sdp-glib.c