summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-20 16:31:12 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-20 16:31:12 +0000
commitbb3cd7888177a4d0e23a5790d3fe26f008345164 (patch)
treec5f3ffab312aad282b1ba6abc24a45c52bef606c /common/Makefile.am
parent9ca184f1e81afa9b68d799ecaae4a16e09684e39 (diff)
Preparation for using the XML parser from GLib
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 412786c9..d9bd00ce 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,9 +1,13 @@
+if GLIB
+sdp_sources = sdp-glib.c
+else
if EXPAT
sdp_sources = sdp-expat.c
else
sdp_sources = sdp-dummy.c
endif
+endif
if INOTIFY
notify_sources = notify-inotify.c
@@ -25,7 +29,7 @@ test_textfile_LDADD = libhelper.a
AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@
-EXTRA_DIST = ppoll.h sdp-dummy.c sdp-expat.c \
- notify-dummy.c notify-inotify.c
+EXTRA_DIST = ppoll.h notify-dummy.c notify-inotify.c \
+ sdp-dummy.c sdp-expat.c sdp-glib.c
MAINTAINERCLEANFILES = Makefile.in