summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-12 00:37:42 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-12 00:37:42 +0000
commitc97480f11bdfdc3cbb867b8127074bcb6b047024 (patch)
tree885dff3c4d9f46567af438af0e266acdc932f281 /common/Makefile.am
parentb6f6c5cf2f85f27b277b891acf0a22c4a068bbbe (diff)
Allow compilation against GLib
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 182d574e..3774edf9 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -5,19 +5,28 @@ else
sdp_sources = sdp-dummy.c
endif
+if GLIB
+glib_sources =
+glib_cflags = @GLIB_CFLAGS@
+else
+glib_sources = glib-ectomy.c
+glib_cflags =
+endif
+
noinst_LIBRARIES = libhelper.a
libhelper_a_SOURCES = oui.h oui.c list.h list.c \
textfile.h textfile.c helper.h helper.c \
- glib-ectomy.h glib-ectomy.c logging.h logging.c \
- dbus.h dbus.c sdp-xml.h sdp-xml.c $(sdp_sources)
+ logging.h logging.c dbus.h dbus.c \
+ sdp-xml.h sdp-xml.c $(sdp_sources) \
+ glib-ectomy.h $(glib_sources)
noinst_PROGRAMS = test_textfile
test_textfile_LDADD = libhelper.a
-AM_CFLAGS = @DBUS_CFLAGS@
+AM_CFLAGS = @DBUS_CFLAGS@ $(glib_cflags)
-EXTRA_DIST = ppoll.h sdp-dummy.c sdp-expat.c
+EXTRA_DIST = ppoll.h sdp-dummy.c sdp-expat.c glib-ectomy.c
MAINTAINERCLEANFILES = Makefile.in