summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-07-29 22:28:35 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-07-29 22:28:35 +0200
commit31aed69c97fdef0ba15c399377ac8208129b5f84 (patch)
treedb3aee06f8c29e1e62ec65c0efeec3fddf656b6b /configure.ac
parent7748a8161c4233f7a8db57dd816cbec57478a709 (diff)
Use configure.ac as it is the preferred name
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac61
1 files changed, 61 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 00000000..9e77f144
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,61 @@
+AC_PREREQ(2.50)
+AC_INIT()
+
+AM_INIT_AUTOMAKE(bluez, 4.x)
+AM_CONFIG_HEADER(config.h)
+
+AM_MAINTAINER_MODE
+
+AC_INIT_BLUEZ
+
+AC_LANG_C
+
+AC_PROG_CC
+AC_PROG_CC_PIE
+AC_PROG_INSTALL
+AC_PROG_YACC
+AM_PROG_LEX
+
+m4_define([_LT_AC_TAGCONFIG], [])
+m4_ifdef([AC_LIBTOOL_TAGS], [AC_LIBTOOL_TAGS([])])
+
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
+AC_FUNC_PPOLL
+
+AC_PATH_GLIB
+AC_PATH_GMODULE
+AC_PATH_DBUS
+AC_PATH_ALSA
+AC_PATH_GSTREAMER
+AC_PATH_USB
+AC_PATH_NETLINK
+AC_PATH_SNDFILE
+
+AC_ARG_BLUEZ
+
+AC_OUTPUT([
+ Makefile
+ include/Makefile
+ lib/Makefile
+ gdbus/Makefile
+ common/Makefile
+ src/Makefile
+ doc/Makefile
+ sbc/Makefile
+ plugins/Makefile
+ network/Makefile
+ serial/Makefile
+ input/Makefile
+ audio/Makefile
+ tools/Makefile
+ rfcomm/Makefile
+ dund/Makefile
+ pand/Makefile
+ hidd/Makefile
+ cups/Makefile
+ test/Makefile
+ scripts/Makefile
+ bluez.pc
+])