summaryrefslogtreecommitdiffstats
path: root/input/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-19 21:40:33 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-19 21:40:33 +0000
commit23875e5b1b633dcfddfe7cbc560d25e306bc9e41 (patch)
tree6a128180c0c9d3b152b65e585d8d3c041103b73f /input/Makefile.am
parentdfc26b1d7936deea5ae306c2c8fc91ff11c68c67 (diff)
Rename service and install it
Diffstat (limited to 'input/Makefile.am')
-rw-r--r--input/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/input/Makefile.am b/input/Makefile.am
index 92652711..71beb94e 100644
--- a/input/Makefile.am
+++ b/input/Makefile.am
@@ -5,6 +5,8 @@ dbusdir = $(sysconfdir)/dbus-1/system.d
dbus_DATA = bluetooth-input.conf
endif
+servicedir = $(libdir)/bluetooth
+
if GLIB
glib_cflags = @GLIB_CFLAGS@
glib_ldadd = @GLIB_LIBS@
@@ -13,11 +15,13 @@ glib_cflags =
glib_ldadd =
endif
-noinst_PROGRAMS = bluetoothd_input
+service_PROGRAMS = bluetoothd-service-input
-bluetoothd_input_SOURCES = main.c input-service.h input-service.c
+bluetoothd_service_input_SOURCES = \
+ main.c input-service.h input-service.c
-bluetoothd_input_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ $(top_builddir)/common/libhelper.a
+LDADD = $(top_builddir)/common/libhelper.a $(glib_ldadd) \
+ @DBUS_LIBS@ @BLUEZ_LIBS@
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ $(glib_cflags)