summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-09-24 02:47:48 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-09-24 02:47:48 +0200
commit5475636b22ecf822cb163d4b3a03e3d5a29cbd51 (patch)
tree2ecebc128a48b3f5965b7e7f5a90d48475ff8893 /plugins/Makefile.am
parent449f0d94a9b1a0272be7d57121ff8d09237f09c4 (diff)
Add first step for providing HAL plugin
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 8565bb29..e8b6ca0f 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,6 +1,12 @@
plugindir = $(libdir)/bluetooth/plugins
+if HAL
+hal_plugins = hal.la
+else
+hal_plugins =
+endif
+
if NETLINK
netlink_plugins = netlink.la
else
@@ -13,7 +19,7 @@ else
service_plugins =
endif
-plugin_LTLIBRARIES = $(netlink_plugins) $(service_plugins)
+plugin_LTLIBRARIES = $(hal_plugins) $(netlink_plugins) $(service_plugins)
noinst_LTLIBRARIES = echo.la storage.la
@@ -21,6 +27,12 @@ echo_la_SOURCES = echo.c
storage_la_SOURCES = storage.c
+if HAL
+hal_la_SOURCES = hal.c
+
+hal_la_LIBADD = @HAL_LIBS@
+endif
+
if NETLINK
netlink_la_SOURCES = netlink.c
@@ -34,7 +46,8 @@ endif
AM_LDFLAGS = -module -avoid-version -no-undefined \
-export-symbols-regex bluetooth_plugin_desc
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@ @NETLINK_CFLAGS@
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@ \
+ @NETLINK_CFLAGS@ @HAL_CFLAGS@
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/src
@@ -46,8 +59,10 @@ all-local:
@$(LN_S) -f $(top_srcdir)/serial/.libs/serial.so
@$(LN_S) -f $(top_srcdir)/network/.libs/network.so
@$(LN_S) -f .libs/service.so
+ @$(LN_S) -f .libs/hal.so
clean-local:
+ @rm -f hal.so
@rm -f service.so
@rm -f network.so
@rm -f serial.so