summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-05-15 02:39:26 +0000
committerMarcel Holtmann <marcel@holtmann.org>2008-05-15 02:39:26 +0000
commit865f1108806df04d4bc1b81d08756924e5d52d6a (patch)
tree7331cc1cddca390a10cb4e879d24ccda1b17da5d /plugins/Makefile.am
parentaacac39879203869ff190be2df7a6f0556ced060 (diff)
Add initial work for netlink plugin
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 6f07b99a..2a3212e1 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,7 +1,13 @@
plugindir = $(libdir)/bluetooth/plugins
-plugin_LTLIBRARIES = libstorage.la
+if NETLINK
+netlink_plugins = libnetlink.la
+else
+netlink_plugins =
+endif
+
+plugin_LTLIBRARIES = libstorage.la $(netlink_plugins)
libstorage_la_SOURCES = storage.c
@@ -9,16 +15,24 @@ noinst_LTLIBRARIES = libecho.la
libecho_la_SOURCES = echo.c
+if NETLINK
+libnetlink_la_SOURCES = netlink.c
+
+libnetlink_la_LIBADD = @NETLINK_LIBS@
+endif
+
AM_LDFLAGS = -module -avoid-version -no-undefined \
-export-symbols-regex bluetooth_plugin_desc
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@ @NETLINK_CFLAGS@
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/hcid
MAINTAINERCLEANFILES = Makefile.in
all-local:
+ @$(LN_S) -f $(top_srcdir)/plugins/.libs/libstorage.so
+ @$(LN_S) -f $(top_srcdir)/plugins/.libs/libnetlink.so
@$(LN_S) -f $(top_srcdir)/input/.libs/libinput.so
@$(LN_S) -f $(top_srcdir)/audio/.libs/libaudio.so
@$(LN_S) -f $(top_srcdir)/serial/.libs/libserial.so
@@ -29,3 +43,5 @@ clean-local:
@rm -f libserial.so
@rm -f libaudio.so
@rm -f libinput.so
+ @rm -f libnetlink.so
+ @rm -f libstorage.so