summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-03-11 20:00:16 +0000
committerMarcel Holtmann <marcel@holtmann.org>2008-03-11 20:00:16 +0000
commit971ed9531285f7de6b2c7a06095a833f9cbad08a (patch)
tree86b7d2035e1a860ed8b6ff43c3d7d7576c777a6c /plugins/Makefile.am
parentf891d23d47274a8788ccdd738ee160f27fb0935b (diff)
Add skeleton for the example plugin
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 02742923..b6020d05 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,2 +1,14 @@
+plugindir = $(libdir)/bluetooth/plugins
+
+plugin_LTLIBRARIES = libecho.la
+
+libecho_la_SOURCES = echo.c
+
+AM_LDFLAGS = -module -avoid-version -export-symbols-regex bluetooth_plugin_desc
+
+AM_CFLAGS = @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+
+INCLUDES = -I$(top_builddir)/common -I$(top_builddir)/hcid
+
MAINTAINERCLEANFILES = Makefile.in