summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-09-03 00:53:43 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-09-03 00:53:43 +0200
commitb0479fa11b7ce68b56aa503f14c4e6655bd25c82 (patch)
tree5fd3ca6a9256e55f416a996a552adb3623472839 /plugins/Makefile.am
parentbb87b45832738400a798fab803c1f3990ed40f8b (diff)
Allow loading of service plugin
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index b07bad4f..8565bb29 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -18,6 +18,7 @@ plugin_LTLIBRARIES = $(netlink_plugins) $(service_plugins)
noinst_LTLIBRARIES = echo.la storage.la
echo_la_SOURCES = echo.c
+
storage_la_SOURCES = storage.c
if NETLINK
@@ -44,8 +45,10 @@ all-local:
@$(LN_S) -f $(top_srcdir)/audio/.libs/audio.so
@$(LN_S) -f $(top_srcdir)/serial/.libs/serial.so
@$(LN_S) -f $(top_srcdir)/network/.libs/network.so
+ @$(LN_S) -f .libs/service.so
clean-local:
+ @rm -f service.so
@rm -f network.so
@rm -f serial.so
@rm -f audio.so