summaryrefslogtreecommitdiffstats
path: root/sbc/Makefile.am
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@nokia.com>2009-01-21 21:08:34 +0200
committerJohan Hedberg <johan.hedberg@nokia.com>2009-01-23 21:15:38 +0200
commitc90eb5ba7e77fa0c430354ed8fdcd67ebdc17b9c (patch)
tree7667a46fec36961d58fb9deb4b7ff55e84eabc81 /sbc/Makefile.am
parentf70d1ada0aba5567fbf67cedfb4a4ba1a9f9852e (diff)
Use of -funroll-loops option to improve SBC encoder performance
Added the use of -funroll-loops gcc option for SBC. Also in order to gain better effect, 'sbc_pack_frame' function body moved to an inline function, which gets instantiated for 4 different subbands/channels combinations. So that 'frame_subbands' and 'frame_channels' arguments become compile time constants and can be better optimized by the compiler.
Diffstat (limited to 'sbc/Makefile.am')
-rw-r--r--sbc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sbc/Makefile.am b/sbc/Makefile.am
index d4ad1941..3feb178e 100644
--- a/sbc/Makefile.am
+++ b/sbc/Makefile.am
@@ -12,7 +12,8 @@ libsbc_la_SOURCES = sbc.h sbc.c sbc_math.h sbc_tables.h \
sbc_primitives.h sbc_primitives_mmx.h sbc_primitives_neon.h \
sbc_primitives.c sbc_primitives_mmx.c sbc_primitives_neon.c
-libsbc_la_CFLAGS = -finline-functions -funswitch-loops -fgcse-after-reload
+libsbc_la_CFLAGS = -finline-functions -funswitch-loops -fgcse-after-reload \
+ -funroll-loops
noinst_PROGRAMS = sbcinfo sbcdec sbcenc $(sndfile_programs)