summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2008-10-18 19:03:30 +0200
committerMarcel Holtmann <marcel@holtmann.org>2008-10-18 19:03:30 +0200
commit53df62e6f94e30bc8f099af7c858d38a94fddf4b (patch)
tree7b250dff95b8821710a620e9fd77a0d17a62d473 /src/Makefile.am
parent132cd4ce6444745547ba2cff0debd9b48892ca46 (diff)
Use dlopen() directly and don't depend on GModule
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2a353a47..af525773 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -22,7 +22,9 @@ bluetoothd_SOURCES = main.c security.c hcid.h sdpd.h \
device.h device.c dbus-common.c dbus-common.h dbus-hci.h dbus-hci.c
bluetoothd_LDADD = $(top_builddir)/common/libhelper.a \
- @GDBUS_LIBS@ @GMODULE_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+ @GDBUS_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@ -ldl
+
+bluetoothd_LDFLAGS = -Wl,--export-dynamic
if MAINTAINER_MODE
plugindir = $(abs_top_srcdir)/plugins
@@ -30,9 +32,8 @@ else
plugindir = $(libdir)/bluetooth/plugins
endif
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ \
- @GLIB_CFLAGS@ @GMODULE_CFLAGS@ @GDBUS_CFLAGS@ \
- -DPLUGINDIR=\""$(plugindir)"\"
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@ \
+ -DPLUGINDIR=\""$(plugindir)"\"
INCLUDES = -I$(top_srcdir)/common