summaryrefslogtreecommitdiffstats
path: root/compat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'compat/Makefile.am')
-rw-r--r--compat/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/compat/Makefile.am b/compat/Makefile.am
new file mode 100644
index 00000000..4054b3e7
--- /dev/null
+++ b/compat/Makefile.am
@@ -0,0 +1,47 @@
+
+bin_PROGRAMS =
+man_MANS =
+
+if HIDD
+bin_PROGRAMS += hidd
+
+hidd_SOURCES = hidd.c hidd.h sdp.c fakehid.c
+
+hidd_LDADD = $(top_builddir)/common/libhelper.a @BLUEZ_LIBS@ -lm
+
+if MANPAGES
+man_MANS += hidd.1
+endif
+endif
+
+if PAND
+bin_PROGRAMS += pand
+
+pand_SOURCES = pand.c pand.h bnep.c sdp.c
+
+pand_LDADD = $(top_builddir)/common/libhelper.a @BLUEZ_LIBS@
+endif
+
+if MANPAGES
+man_MANS += pand.1
+endif
+
+if DUND
+bin_PROGRAMS += dund
+
+dund_SOURCES = dund.c dund.h lib.h sdp.c dun.c msdun.c
+
+dund_LDADD = $(top_builddir)/common/libhelper.a @BLUEZ_LIBS@
+endif
+
+if MANPAGES
+man_MANS += dund.1
+endif
+
+AM_CFLAGS = @BLUEZ_CFLAGS@
+
+INCLUDES = -I$(top_srcdir)/common
+
+EXTRA_DIST = fakehid.txt hidd.1 pand.1 dund.1
+
+MAINTAINERCLEANFILES = Makefile.in