summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am19
1 files changed, 6 insertions, 13 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 336f2a25..73f11f3d 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -7,14 +7,6 @@ endif
servicedir = $(libdir)/bluetooth
-if GLIB
-glib_cflags = @GLIB_CFLAGS@
-glib_ldadd = @GLIB_LIBS@
-else
-glib_cflags =
-glib_ldadd =
-endif
-
noinst_PROGRAMS = bluetoothd
service_PROGRAMS = bluetoothd-service-echo
@@ -23,21 +15,22 @@ bluetoothd_SOURCES = main.c system.h \
manager.h manager.c database.h database.c \
adapter.h adapter.c service.h service.c
-bluetoothd_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ \
- $(top_builddir)/sdpd/libsdpserver.a \
- $(top_builddir)/common/libhelper.a
+bluetoothd_LDADD = \
+ $(top_builddir)/common/libhelper.a \
+ $(top_builddir)/sdpd/libsdpserver.a \
+ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
bluetoothd_service_echo_SOURCES = echo.c
bluetoothd_service_echo_LDADD = \
$(top_builddir)/common/libhelper.a \
- $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@
+ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
if EXPAT
bluetoothd_LDADD += -lexpat
endif
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ $(glib_cflags)
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/sdpd