summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 67758137..be4b738f 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -1,9 +1,17 @@
+if GLIB
+glib_cflags = @GLIB_CFLAGS@
+glib_ldadd = @GLIB_LIBS@
+else
+glib_cflags =
+glib_ldadd =
+endif
+
noinst_PROGRAMS = bluetoothd
bluetoothd_SOURCES = main.c
-bluetoothd_LDADD = @DBUS_LIBS@ @BLUEZ_LIBS@ \
+bluetoothd_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ \
$(top_builddir)/hcid/libhciserver.a \
$(top_builddir)/sdpd/libsdpserver.a \
$(top_builddir)/common/libhelper.a
@@ -12,7 +20,7 @@ if EXPAT
bluetoothd_LDADD += -lexpat
endif
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ $(glib_cflags)
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/hcid -I$(top_srcdir)/sdpd