summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am31
1 files changed, 28 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5505391e..561741e7 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,30 @@
-EXTRA_DIST = manager-api.txt adapter-api.txt device-api.txt agent-api.txt \
- serial-api.txt network-api.txt input-api.txt audio-api.txt
+DOC_MODULE = bluez
+
+DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.xml
+
+DOC_SOURCE_DIR = ../src
+
+SCAN_OPTIONS = --rebuild-sections
+
+MKDB_OPTIONS = --sgml-mode --output-format=xml --tmpl-dir=. \
+ --source-suffixes=c,h
+
+MKTMPL_OPTIONS = --output-dir=.
-MAINTAINERCLEANFILES = Makefile.in
+HFILE_GLOB = $(top_srcdir)/src/*.h
+CFILE_GLOB = $(top_srcdir)/src/*.c
+
+IGNORE_HFILES =
+
+MAINTAINERCLEANFILES = Makefile.in \
+ $(DOC_MODULE).types $(DOC_MODULE)-*.txt *.sgml
+
+if ENABLE_GTK_DOC
+include $(top_srcdir)/doc/gtk-doc.make
+else
+EXTRA_DIST = $(DOC_MAIN_SGML_FILE) $(content_files)
+endif
+
+EXTRA_DIST += manager-api.txt adapter-api.txt device-api.txt agent-api.txt \
+ serial-api.txt network-api.txt input-api.txt audio-api.txt