summaryrefslogtreecommitdiffstats
path: root/input/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'input/Makefile.am')
-rw-r--r--input/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/input/Makefile.am b/input/Makefile.am
index bf8a4c0a..98ce9287 100644
--- a/input/Makefile.am
+++ b/input/Makefile.am
@@ -5,17 +5,17 @@ plugindir = $(libdir)/bluetooth/plugins
plugin_LTLIBRARIES = input.la
input_la_SOURCES = main.c manager.h manager.c \
- server.h server.c device.h device.c \
- fakehid.c fakehid.h
+ server.h server.c device.h device.c \
+ fakehid.c fakehid.h
LDADD = $(top_builddir)/common/libhelper.a \
@GDBUS_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
endif
-AM_LDFLAGS = -module -avoid-version -no-undefined \
- -export-symbols-regex bluetooth_plugin_desc
+AM_LDFLAGS = -module -avoid-version -no-undefined
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
+AM_CFLAGS = -fvisibility=hidden \
+ @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/src