summaryrefslogtreecommitdiffstats
path: root/network/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'network/Makefile.am')
-rw-r--r--network/Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/network/Makefile.am b/network/Makefile.am
index 2f8a7c3d..da92a8c2 100644
--- a/network/Makefile.am
+++ b/network/Makefile.am
@@ -1,28 +1,24 @@
if NETWORKSERVICE
-if CONFIGFILES
-confdir = $(sysconfdir)/bluetooth
+plugindir = $(libdir)/bluetooth/plugins
-conf_DATA = network.service
-endif
-
-servicedir = $(libdir)/bluetooth
+plugin_LTLIBRARIES = libnetwork.la
-service_PROGRAMS = bluetoothd-service-network
-
-bluetoothd_service_network_SOURCES = main.c \
+libnetwork_la_SOURCES = main.c \
manager.h manager.c \
server.h server.c bridge.h bridge.c \
connection.h connection.c common.h common.c
LDADD = $(top_builddir)/common/libhelper.a \
- @GLIB_LIBS@ @HAL_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
endif
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @HAL_CFLAGS@ @GLIB_CFLAGS@
+AM_LDFLAGS = -module -avoid-version -export-symbols-regex bluetooth_plugin_desc
+
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
-INCLUDES = -I$(top_srcdir)/common
+INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/hcid
-EXTRA_DIST = network.service network.conf network-api.txt test-network
+EXTRA_DIST = network.conf network-api.txt test-network
MAINTAINERCLEANFILES = Makefile.in