summaryrefslogtreecommitdiffstats
path: root/rfcomm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rfcomm/Makefile.am')
-rw-r--r--rfcomm/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/rfcomm/Makefile.am b/rfcomm/Makefile.am
index 6b7a9eee..83b1f3f2 100644
--- a/rfcomm/Makefile.am
+++ b/rfcomm/Makefile.am
@@ -2,12 +2,23 @@
# $Id$
#
-sbin_PROGRAMS = rfcomm
+mandir = $(prefix)/share/man
+confdir = /etc/bluetooth
+
+bin_PROGRAMS = rfcomm
rfcomm_SOURCES = main.c parser.h parser.y lexer.l kword.h kword.c
+rfcomm_CONFIG = rfcomm.conf
-man_MANS = rfcomm.8
+man_MANS = rfcomm.8
YFLAGS = -d
CLEANFILES = lexer.c parser.c parser.h
+
+EXTRA_DIST = $(man_MANS) $(rfcomm_CONFIG)
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(confdir)
+ [ -f $(DESTDIR)$(confdir)/$(rfcomm_CONFIG) ] || \
+ $(INSTALL_DATA) $(srcdir)/$(rfcomm_CONFIG) $(DESTDIR)$(confdir)/$(rfcomm_CONFIG)