summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 8e05086b..6130c842 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -4,10 +4,8 @@
bin_SCRIPTS = bluepin
-EXTRA_DIST = bluepin bluetooth.rc.rh bluetooth.rc.deb create_dev
+EXTRA_DIST = bluepin bluetooth.init bluetooth.default create_dev
install-data-local:
- [ ! -f /etc/redhat-release -o ! -f /etc/mandrake-release ] || \
- $(INSTALL) -D -m 755 $(srcdir)/bluetooth.rc.rh $(DESTDIR)$(sysconfdir)/rc.d/init.d/bluetooth
- [ ! -f /etc/debian_version ] || \
- $(INSTALL) -D -m 755 $(srcdir)/bluetooth.rc.deb $(DESTDIR)$(sysconfdir)/init.d/bluetooth
+ $(INSTALL) -D -m 755 $(srcdir)/bluetooth.init $(DESTDIR)$(sysconfdir)/init.d/bluetooth
+ $(INSTALL) -D -m 644 $(srcdir)/bluetooth.default $(DESTDIR)$(sysconfdir)/default/bluetooth