summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 741ae080..e77f3f12 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -2,12 +2,15 @@
# $Id$
#
+if BLUEPIN
bin_SCRIPTS = bluepin
+endif
EXTRA_DIST = bluepin bluetooth.init bluetooth.default create_dev
MAINTAINERCLEANFILES = Makefile.in
+if INITSCRIPTS
install-data-local:
$(INSTALL) -D -m 755 $(srcdir)/bluetooth.init $(DESTDIR)$(sysconfdir)/init.d/bluetooth
$(mkinstalldirs) $(DESTDIR)$(sysconfdir)/default
@@ -17,3 +20,4 @@ install-data-local:
uninstall-local:
@rm -f $(DESTDIR)$(sysconfdir)/init.d/bluetooth
@rm -f $(DESTDIR)$(sysconfdir)/default/bluetooth
+endif