summaryrefslogtreecommitdiffstats
path: root/serial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'serial/Makefile.am')
-rw-r--r--serial/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/serial/Makefile.am b/serial/Makefile.am
index a3bd6d1f..4fa455f5 100644
--- a/serial/Makefile.am
+++ b/serial/Makefile.am
@@ -5,17 +5,17 @@ plugindir = $(libdir)/bluetooth/plugins
plugin_LTLIBRARIES = serial.la
serial_la_SOURCES = main.c \
- manager.h manager.c port.h port.c \
- storage.h storage.c proxy.h proxy.c
+ manager.h manager.c port.h port.c \
+ storage.h storage.c proxy.h proxy.c
LDADD = $(top_builddir)/common/libhelper.a \
@GDBUS_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
endif
-AM_LDFLAGS = -module -avoid-version -no-undefined \
- -export-symbols-regex bluetooth_plugin_desc
+AM_LDFLAGS = -module -avoid-version -no-undefined
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
+AM_CFLAGS = -fvisibility=hidden \
+ @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@
INCLUDES = -I$(top_srcdir)/common -I$(top_srcdir)/src