summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-05 10:04:04 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-05 10:04:04 +0000
commit3a96e4ffd99ec3f125e1891155ecb751b6e313a1 (patch)
treef64f075a2100392883429e9aaa467be26a001669 /Makefile.am
parent03b9ca6d4ecf2577958530b8390d675c73a58825 (diff)
2003-04-05 Havoc Pennington <hp@pobox.com>
* Makefile.am (coverage-report.txt): add target "coverage-report.txt" * test/decode-gcov.c: hack up a little program to suck data out of gcov files. Yes this is sort of silly. * configure.in: define something in config.h and do an AM_CONDITIONAL when gcov is enabled
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ec5e7fc..25beb75e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,3 +24,33 @@ EXTRA_DIST = \
all-local: Doxyfile
+if DBUS_GCOV_ENABLED
+clean-gcov:
+ find -name "*.da" -o -name "*.gcov" | xargs rm || true
+
+## .PHONY so it always rebuilds it
+.PHONY: coverage-report.txt
+coverage-report.txt:
+ GCOV_FILES=`find -name "*.bbg"` ; \
+ C_FILES= ; \
+ for F in $$GCOV_FILES; do \
+ C=`echo $$F | sed -e 's/.bbg/.c/g'` ; \
+ DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
+ if test -e $$DA ; then \
+ C_FILES="$$C_FILES $$C" ; \
+ fi ; \
+ done ; \
+ echo $$C_FILES ; \
+ $(top_builddir)/test/decode-gcov --report $$C_FILES > coverage-report.txt
+
+check-coverage: clean-gcov all check coverage-report.txt
+ cat coverage-report.txt
+
+else
+coverage-report.txt:
+ echo "Need to reconfigure with --enable-gcov"
+
+check-coverage:
+ echo "Need to reconfigure with --enable-gcov"
+
+endif \ No newline at end of file