summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-07-14 16:20:12 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-07-14 16:20:12 +0000
commita929c9a3b465db8b7e17b9b39936c612c2621a7c (patch)
treed1764257d1bd56f8e6a044516ccfc9bc44f7f9f5 /Makefile.am
parent5efe8e7f1d97931710558495a951e0b35afbfb72 (diff)
* Remove all bindings
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am53
1 files changed, 6 insertions, 47 deletions
diff --git a/Makefile.am b/Makefile.am
index 816d653d..118cbeea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,56 +1,15 @@
-
-if HAVE_GLIB
- GLIB_SUBDIR=glib
- GLIB_PC=dbus-glib-1.pc
-endif
-
-if HAVE_QT
- QT_SUBDIR=qt
- QT_PC=dbus-qt4-1.pc
-endif
-
-if HAVE_QT3
- QT3_SUBDIR=qt3
-endif
-
-if DBUS_USE_GCJ
- GCJ_SUBDIR=gcj
-endif
-
-if DBUS_USE_CSC
- MONO_SUBDIR=mono
- MONO_PC=dbus-sharp.pc
-endif
-
-if HAVE_PYTHON
- PYTHON_SUBDIR=python
-endif
-
-## really we should require gcj/mcs/python also but since they are
-## annoying to install, we don't for now
-dist-local:
- if test -z "$(QT_SUBDIR)" || test -z "$(GLIB_SUBDIR)" ; then \
- echo "You have to build with Qt and GLib to make dist" ; \
- fi
-
-SUBDIRS=dbus bus doc $(GLIB_SUBDIR) $(GCJ_SUBDIR) $(MONO_SUBDIR) $(QT_SUBDIR) $(QT3_SUBDIR) $(PYTHON_SUBDIR) tools test
-DIST_SUBDIRS=dbus bus doc glib qt qt3 gcj mono python tools test
+SUBDIRS=dbus bus doc tools test
+DIST_SUBDIRS=dbus bus doc tools test
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = dbus-1.pc $(GLIB_PC) $(QT_PC) $(MONO_PC)
+pkgconfig_DATA = dbus-1.pc
DISTCLEANFILES = \
- dbus-1.pc \
- $(GLIB_PC) \
- $(QT_PC) \
- $(MONO_PC)
+ dbus-1.pc
EXTRA_DIST = \
HACKING \
- dbus-1.pc.in \
- dbus-glib-1.pc.in \
- dbus-qt4-1.pc.in \
- dbus-sharp.pc.in
+ dbus-1.pc.in
all-local: Doxyfile
@@ -61,7 +20,7 @@ clean-gcov:
clean-bbg:
find -name "*.bbg" -o -name "*.bb" | xargs rm || true
-GCOV_DIRS=dbus bus $(GLIB_SUBDIR) $(QT_SUBDIR)
+GCOV_DIRS=dbus bus
## .PHONY so it always rebuilds it
.PHONY: coverage-report.txt