summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2004-12-24 17:54:01 +0000
committerHavoc Pennington <hp@redhat.com>2004-12-24 17:54:01 +0000
commitb8a309ac940374ead27618508ab8f81665ff7d9d (patch)
treedaa672a607300f214848db72737fa7cdbc46cad8 /Makefile.am
parentf019ebdd20fd92f81117515f683872ff36b24b09 (diff)
2004-12-24 Havoc Pennington <hp@redhat.com>
* test/decode-gcov.c: change to use .gcno and .gcda files, but the file format has also changed and I haven't adapted to that yet * Makefile.am: load .gcno files from latest gcc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 14 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 47ac1def..886618b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,20 +59,20 @@ GCOV_DIRS=dbus bus $(GLIB_SUBDIR) $(QT_SUBDIR)
## .PHONY so it always rebuilds it
.PHONY: coverage-report.txt
coverage-report.txt:
- BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
- C_FILES= ; \
- for F in $$BBG_FILES ; do \
- F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
- C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g'` ; \
- B=`basename $$F .bbg` ; \
- D=`dirname $$F` ; \
- DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
- DA_libs=`echo $$D/.libs/$$B/.da` ; \
- if test -e $$DA || test -e $$DA_libs; then \
- C_FILES="$$C_FILES $$C" ; \
- fi ; \
- done ; \
- echo $$C_FILES ; \
+ BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg" -o -name "*.gcno"` ; \
+ C_FILES= ; \
+ for F in $$BBG_FILES ; do \
+ F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
+ C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g' | sed -e 's/.gcno/.c/g'` ; \
+ B=`basename $$F .bbg` ; \
+ D=`dirname $$F` ; \
+ DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
+ DA_libs=`echo $$D/.libs/$$B/.da` ; \
+ if test -e $$DA || test -e $$DA_libs; then \
+ C_FILES="$$C_FILES $$C" ; \
+ fi ; \
+ done ; \
+ echo $$C_FILES ; \
$(top_builddir)/test/decode-gcov --report $$C_FILES > coverage-report.txt
check-coverage: clean-gcov all check coverage-report.txt