summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-10-15 21:09:40 +0000
committerHavoc Pennington <hp@redhat.com>2003-10-15 21:09:40 +0000
commitcd077dc8f2a8876f7ce50229e855d138b8310a0e (patch)
treeb9d6d6667bb5f7fd0522a7de1ce593d498a0796b /Makefile.am
parent9f2d0d86bbf4315aa1c51167f9dd18e8cb0af479 (diff)
2003-10-14 Havoc Pennington <hp@redhat.com>
* test/decode-gcov.c: support gcc 3.3 also, though gcc 3.3 seems to have a bug keeping it from outputting the .da files sometimes (string_get_string): don't append garbage nul bytes to the string.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 200ee64e..fce48628 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,12 +47,33 @@ if DBUS_GCOV_ENABLED
clean-gcov:
find -name "*.da" -o -name "*.gcov" | xargs rm || true
+clean-bbg:
+ find -name "*.bbg" -o -name "*.bb" | xargs rm || true
+
+GCOV_DIRS=dbus bus test $(GLIB_SUBDIR) $(QT_SUBDIR)
+
## .PHONY so it always rebuilds it
.PHONY: coverage-report.txt
coverage-report.txt:
- GCOV_FILES=`find dbus bus $(GLIB_SUBDIR) $(QT_SUBDIR) -name "*.bbg"` ; \
+ BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
+ for F in $$BBG_FILES ; do \
+ F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
+ if test $$F != $$F_nolibs ; then \
+ echo "Moving $$F to $$F_nolibs" ; \
+ mv -f $$F $$F_nolibs ; \
+ fi ; \
+ done ; \
+ DA_FILES=`find $(GCOV_DIRS) -name "*.da"` ; \
+ for F in $$DA_FILES ; do \
+ F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
+ if test $$F != $$F_nolibs ; then \
+ echo "Moving $$F to $$F_nolibs" ; \
+ mv -f $$F $$F_nolibs ; \
+ fi ; \
+ done ; \
+ BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg"` ; \
C_FILES= ; \
- for F in $$GCOV_FILES; do \
+ for F in $$BBG_FILES ; do \
C=`echo $$F | sed -e 's/.bbg/.c/g'` ; \
DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
if test -e $$DA ; then \