summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSeth Nickell <seth@gnome.org>2003-09-22 05:45:59 +0000
committerSeth Nickell <seth@gnome.org>2003-09-22 05:45:59 +0000
commitf4cffc0e49d48a8dbf158230d7e816d8713566da (patch)
treed22625c371ad3fa2eae127c0a825bd5b26652c61 /Makefile.am
parentc9332907b035b52103c5569119d0a7c9fbcb76ac (diff)
2003-09-21 Seth Nickell <seth@gnome.org>
First checkin of the Python bindings. * python/.cvsignore: * python/Makefile.am: * python/dbus_bindings.pyx.in: * python/dbus_h_wrapper.h: Pieces for Pyrex to operate on, building a dbus_bindings.so python module for low-level access to the DBus APIs. * python/dbus.py: High-level Python module for accessing DBus objects. * configure.in: * Makefile.am: Build stuff for the python bindings. * acinclude.m4: Extra macro needed for finding the Python C header files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5bb5ae6a..47329972 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,8 +16,11 @@ if DBUS_USE_MCS
MONO_SUBDIR=mono
endif
+if HAVE_PYTHON
+ PYTHON_SUBDIR=python
+endif
-SUBDIRS=dbus bus doc $(GLIB_SUBDIR) $(GCJ_SUBDIR) $(MONO_SUBDIR) $(QT_SUBDIR) test tools
+SUBDIRS=dbus bus doc $(GLIB_SUBDIR) $(GCJ_SUBDIR) $(MONO_SUBDIR) $(QT_SUBDIR) $(PYTHON_SUBDIR) test tools
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = dbus-1.pc $(GLIB_PC)