summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2007-07-24 11:58:08 +0000
committerRichard Hughes <richard@hughsie.com>2007-07-24 11:58:08 +0000
commit0cb8dd64a94fd3b57b37a68a6611a125689bf5df (patch)
treefbfe6c4538cee81a88d8bd6cbff06a1c59b7ab25 /bus/Makefile.am
parentd6fddc64b5ed5ddd7b087679b4bd4b8d79e2fe69 (diff)
2007-07-24 Richard Hughes <richard@hughsie.com>
* bus/Makefile.am: * bus/config-parser.c: (bus_config_parser_unref), (start_busconfig_child), (bus_config_parser_end_element), (servicehelper_path), (bus_config_parser_content), (bus_config_parser_finished), (bus_config_parser_get_servicehelper), (test_default_session_servicedirs), (test_default_system_servicedirs), (bus_config_parser_test): * bus/config-parser.h: Make the config-parser code use the common config code. Also add the session and systemdirs stuff, and make the config parser aware of the servicehelper field.
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index f7fec99a..d8dd22d4 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -2,6 +2,7 @@
configdir=$(sysconfdir)/dbus-1
INCLUDES=-I$(top_srcdir) $(DBUS_BUS_CFLAGS) \
+ -DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
-DDAEMON_NAME=\"dbus-daemon\" -DDBUS_COMPILATION
EFENCE=
@@ -34,10 +35,13 @@ endif
BUS_SOURCES= \
activation.c \
activation.h \
+ activation-exit-codes.h \
bus.c \
bus.h \
config-parser.c \
config-parser.h \
+ config-parser-common.c \
+ config-parser-common.h \
connection.c \
connection.h \
desktop-file.c \