summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2005-03-12 16:33:01 +0000
committerColin Walters <walters@verbum.org>2005-03-12 16:33:01 +0000
commit3dea5c183f65c3f924fb442bf606dfeb50f028a4 (patch)
tree0ac180fdc5c7766d003863717ef6cbeff8237806 /bus/Makefile.am
parent3c1d2d65654f92f24d3e5c9c5b88d76a10f72822 (diff)
2005-03-11 Colin Walters <walters@verbum.org>
* glib/Makefile.am: Generate dbus-glib-bindings.h and install it. * bus/print-introspect.c: New file; prints introspection data for a given name and object path. * bus/run-with-tmp-session-bus.sh: New file, refactored from test/glib/run-test.sh. Creates a temporary session bus and runs another program. * test/glib/run-test.sh: Refactor to invoke run-with-tmp-session-bus.sh. * bus/driver.c (bus_driver_handle_introspect): Fix to print new introspection format. Also change to use DBUS_TYPE_x_AS_STRING macros instead of hardcoding. * glib/.cvsignore, bus/.cvsignore, test/glib/.cvsignore: Update.
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index b6480856..f6e04ee7 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -77,7 +77,7 @@ endif
## we use noinst_PROGRAMS not check_PROGRAMS so that we build
## even when not doing "make check"
-noinst_PROGRAMS=$(TESTS)
+noinst_PROGRAMS=$(TESTS) print-introspect
bus_test_SOURCES= \
$(BUS_SOURCES) \
@@ -85,9 +85,20 @@ bus_test_SOURCES= \
bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
+print_introspect_SOURCES = print-introspect.c
+print_introspect_LDADD = $(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
+
+run-with-tmp-session-bus.sh: dbus-daemon
+
+all-local: dbus-bus-introspect.xml
+
+dbus-bus-introspect.xml: $(srcdir)/run-with-tmp-session-bus.sh
+ DBUS_TOP_BUILDDIR=$(top_builddir) $(srcdir)/run-with-tmp-session-bus.sh ./print-introspect org.freedesktop.DBus /org/freedesktop/DBus > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
+
## mop up the gcov files
clean-local:
/bin/rm *.bb *.bbg *.da *.gcov || true
+ /bin/rm -f run-with-tmp-session-bus.conf
install-data-hook:
$(mkinstalldirs) $(DESTDIR)/$(localstatedir)/run/dbus
@@ -125,4 +136,4 @@ man_MANS = dbus-daemon.1
#### Extra dist
-EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) $(man_MANS) $(MAN_IN_FILES)
+EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) $(man_MANS) $(MAN_IN_FILES) run-with-tmp-session-bus.sh