summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-30 21:15:44 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-30 21:15:44 +0000
commit42d47c5f805b61892456b17a0e5b2632d73745bd (patch)
tree3549facdff6fe32eda39c910ae1239490ef487c6 /bus/Makefile.am
parent410a80c43126376e9308a03a7cef108716018f5a (diff)
2003-04-30 Havoc Pennington <hp@redhat.com>
* Makefile.am: add a check-local that complains if you didn't configure with --enable-tests
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 823d9cc4..9836ffd3 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -102,4 +102,12 @@ endif
#### Extra dist
-EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) \ No newline at end of file
+EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES)
+
+if DBUS_BUILD_TESTS
+### nothing
+else
+check-local:
+ echo "You have to configure with --enable-tests to make check" ; \
+ exit 1
+endif