summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2008-01-14 19:00:36 -0500
committerJohn (J5) Palmieri <johnp@redhat.com>2008-01-14 19:00:36 -0500
commit831a0d71c4767f81dd69f4078b393ff73d22172a (patch)
tree5d98096a8108455c34e368901e75698eb0ef797c /bus/Makefile.am
parentcbf5d0b6fab515948155d0816ed84657f5e8ebb3 (diff)
add inotify support (FDO Bz#13268)
2008-01-14 John (J5) Palmieri <johnp@redhat.com> * patch by Frederic Crozat <fcrozat at mandriva dot com> (FDO Bz# 13268) * add inotify support * bus/Makefile.am: add inotify module to the build * bus/dir-watch-inotify.c: inotify module based off the dnotify and kqueue modules * configure.in: add checks and switch for inotify also add a printout at the end of configure if inotify and kqueue support is being built in (dnotify already had this)
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 4648a31d..3b4f69db 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -25,12 +25,16 @@ endif
if DBUS_BUS_ENABLE_KQUEUE
DIR_WATCH_SOURCE=dir-watch-kqueue.c
else
+if DBUS_BUS_ENABLE_INOTIFY
+DIR_WATCH_SOURCE=dir-watch-inotify.c
+else
if DBUS_BUS_ENABLE_DNOTIFY_ON_LINUX
DIR_WATCH_SOURCE=dir-watch-dnotify.c
else
DIR_WATCH_SOURCE=dir-watch-default.c
endif
endif
+endif
BUS_SOURCES= \
activation.c \