summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-03-26 03:58:11 +0000
committerHavoc Pennington <hp@redhat.com>2003-03-26 03:58:11 +0000
commit90ed1d84588a84697051e643175452c50d682ece (patch)
treea8ee3ecb05c584194d5c74e98038c24e5fdabe9b /bus/Makefile.am
parent17e82f5728d3fc8abd41c816b1c34c506339c7a7 (diff)
2003-03-25 Havoc Pennington <hp@redhat.com>
* throughout - add more _DBUS_ASSERT_ERROR_IS_CLEAR * configure.in: add --with-xml option to specify XML library, right now only libxml is supported. * bus/config-loader-libxml.c, config-parser.c: sync some minor nonworking code between home and work, still just stubs
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index bc64032c..37d3de06 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -6,11 +6,17 @@ EFENCE=
bin_PROGRAMS=dbus-daemon-1
+if DBUS_USE_LIBXML
+XML_SOURCES=config-loader-libxml.c
+endif
+
BUS_SOURCES= \
activation.c \
activation.h \
bus.c \
bus.h \
+ config-parser.c \
+ config-parser.h \
connection.c \
connection.h \
desktop-file.c \
@@ -28,7 +34,8 @@ BUS_SOURCES= \
test.c \
test.h \
utils.c \
- utils.h
+ utils.h \
+ $(XML_SOURCES)
dbus_daemon_1_SOURCES= \
$(BUS_SOURCES) \
@@ -57,7 +64,7 @@ bus_test_SOURCES= \
$(BUS_SOURCES) \
test-main.c
-bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la
+bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
## mop up the gcov files
clean-local: