summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2005-03-17 17:48:29 +0000
committerColin Walters <walters@verbum.org>2005-03-17 17:48:29 +0000
commita65587676f6791ff6a7c9ed98bbc53d740f51fa8 (patch)
tree1e5fb5030cf55dc63dc388e6da4a7918dfa9251f /bus/Makefile.am
parent6180ae6941aea083f5b8f3c4d3f16c928935bcaf (diff)
2005-03-17 Colin Walters <walters@verbum.org>
* bus/print-introspect.c: Move to tools/. * bus/run-with-tmp-session-bus.sh: Ditto. * glib/Makefile.am (dbus-glib-bindings.h): Move generation to tools/Makefile.am. * test/glib/run-test.sh: Update to handle move of run-with-tmp-session-bus.sh. * test/glib/test-service-glib.c: Update to handle move of dbus-glib-bindings.h. * tools/print-introspect.c: Moved here from bus/, and ported to GLib bindings. * tools/run-with-tmp-session-bus.sh: Moved here from bus/. * tools/Makefile.am: Generate dbus-glib-bindings.h and dbus-bus-introspect.xml here. * tools/.cvsignore, glib/.cvsignore, bus/.cvsignore: Update.
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am15
1 files changed, 2 insertions, 13 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index a1fb76a0..56770656 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -77,7 +77,7 @@ endif
## we use noinst_PROGRAMS not check_PROGRAMS so that we build
## even when not doing "make check"
-noinst_PROGRAMS=$(TESTS) print-introspect
+noinst_PROGRAMS=$(TESTS)
bus_test_SOURCES= \
$(BUS_SOURCES) \
@@ -85,20 +85,9 @@ bus_test_SOURCES= \
bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
-print_introspect_SOURCES = print-introspect.c
-print_introspect_LDADD = $(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
-
-run-with-tmp-session-bus.sh: dbus-daemon
-
-all-local: dbus-bus-introspect.xml
-
-dbus-bus-introspect.xml: $(srcdir)/run-with-tmp-session-bus.sh dbus-daemon
- DBUS_TOP_BUILDDIR=$(top_builddir) $(srcdir)/run-with-tmp-session-bus.sh ./print-introspect org.freedesktop.DBus /org/freedesktop/DBus > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
-
## mop up the gcov files
clean-local:
/bin/rm *.bb *.bbg *.da *.gcov || true
- /bin/rm -f run-with-tmp-session-bus.conf
install-data-hook:
$(mkinstalldirs) $(DESTDIR)/$(localstatedir)/run/dbus
@@ -136,4 +125,4 @@ man_MANS = dbus-daemon.1
#### Extra dist
-EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) $(man_MANS) $(MAN_IN_FILES) run-with-tmp-session-bus.sh
+EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) $(man_MANS) $(MAN_IN_FILES)