summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-18 05:52:11 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-18 05:52:11 +0000
commite0b284c7e38f0c002b2173d85ab89dc18700867c (patch)
treef309b8387d4a4487624154774ffdf5fcb3bdd182 /bus/Makefile.am
parent3df260c07102745c5606c313af862558f105f83e (diff)
2003-04-18 Havoc Pennington <hp@pobox.com>
* dbus/dbus-mainloop.c (_dbus_loop_iterate): fix UMR in verbose debug spew * dbus/dbus-auth.c (handle_client_data_cookie_sha1_mech): fix OOM handling problem * dbus/dbus-keyring.c (_dbus_keyring_new_homedir): only whine about DBUS_TEST_HOMEDIR once * bus/Makefile.am (TESTS_ENVIRONMENT): put DBUS_TEST_HOMEDIR in the environment * bus/dispatch.c (bus_dispatch_sha1_test): actually load sha1 config file so we test the right thing Throughout: assorted docs improvements
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 85f47ddc..823d9cc4 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -63,7 +63,7 @@ dbus_daemon_1_LDADD= \
## so if adding tests not to be run in make check, don't add them to
## TESTS
if DBUS_BUILD_TESTS
-TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_builddir)/test/data
+TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_builddir)/test/data DBUS_TEST_HOMEDIR=$(top_builddir)/dbus
TESTS=bus-test
else
TESTS=