summaryrefslogtreecommitdiffstats
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-05-15 19:59:19 +0000
committerHavoc Pennington <hp@redhat.com>2003-05-15 19:59:19 +0000
commitf0f4335bd97732d156f0b35762f61ba2d88514ab (patch)
treee9003854f9a9ed90ec3d5778fb7def500709b238 /bus/Makefile.am
parente9cb382daf7cef6396d1777c99f27a050f7ad4a8 (diff)
2003-05-15 Havoc Pennington <hp@redhat.com>dbus-0.11
* configure.in: 0.11 * NEWS: update * bus/Makefile.am (initddir): apparently we are supposed to put init scripts in /etc/rc.d/init.d not /etc/init.d * bus/Makefile.am: remove the "you must --enable-tests to make check" as it broke distcheck * bus/Makefile.am (install-data-hook): create /etc/dbus-1/system.d
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index ba6524c7..8c316f30 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -85,6 +85,7 @@ clean-local:
install-data-hook:
$(mkinstalldirs) $(DESTDIR)/$(localstatedir)/run/dbus
+ $(mkinstalldirs) $(DESTDIR)/$(configdir)/system.d
#### Init scripts fun
SCRIPT_IN_FILES=messagebus.in
@@ -92,7 +93,7 @@ SCRIPT_IN_FILES=messagebus.in
## Red Hat start
if DBUS_INIT_SCRIPTS_RED_HAT
-initddir=$(sysconfdir)/init.d
+initddir=$(sysconfdir)/rc.d/init.d
initd_SCRIPTS= \
messagebus
@@ -106,11 +107,3 @@ man_MANS = dbus-daemon-1.1
#### Extra dist
EXTRA_DIST=$(CONFIG_IN_FILES) $(SCRIPT_IN_FILES) $(man_MANS) $(MAN_IN_FILES)
-
-if DBUS_BUILD_TESTS
-### nothing
-else
-check-local:
- echo "You have to configure with --enable-tests to make check" ; \
- exit 1
-endif