summaryrefslogtreecommitdiffstats
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2007-04-26 09:30:38 +0000
committerRalf Habacker <ralf.habacker@freenet.de>2007-04-26 09:30:38 +0000
commit4bd8418548e668cd3fbf8ea5f6aa21d28e14e386 (patch)
treea0098f26c866766189bb6ecf224fd0d3c83f0c2f /cmake/CMakeLists.txt
parentc4a5da3e597e5ff782b52e48bc8ed2996ea90fa0 (diff)
* cmake: added debug postfixes to debug exe's for easier debugging.
* dbus\dbus-sysdeps-win.c (_dbus_win_set_error_from_win_error): print error code in case no string message is available.
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index ccd63e01..1b5249c2 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -1,6 +1,6 @@
set (PACKAGE dbus)
set (VERSION_MAJOR "1")
-set (VERSION_MINOR "0")
+set (VERSION_MINOR "1")
set (VERSION_PATCH "0")
set (VERSION ${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH} )
project(${PACKAGE})
@@ -75,6 +75,11 @@ if(MSVC)
SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} /FIconfig.h ${MSVC_W_ERROR} ${MSVC_W_DISABLE}")
endif(MSVC)
+if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ # dll postfix is set to 'd' by default
+ set (CMAKE_EXE_POSTFIX "d")
+endif(CMAKE_BUILD_TYPE STREQUAL "Debug")
+
#########################################################################
# Windows CE