summaryrefslogtreecommitdiffstats
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2007-03-14 00:16:05 +0000
committerRalf Habacker <ralf.habacker@freenet.de>2007-03-14 00:16:05 +0000
commitc01a63299e1ebcf9193a11c484e0a551487f3257 (patch)
tree39290d7e8c416e15238b8ab52a80c649c6a62db6 /cmake/CMakeLists.txt
parentd372907895ffed3a2df06146d5dcc8601eab04dc (diff)
* cmake: added doxygen support
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 9eb65b2e..e682a17b 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -228,11 +228,6 @@ OPTION(DBUS_DISABLE_CHECKS "Disable public API sanity checking" OFF)
#AC_ARG_ENABLE(xml-docs, AS_HELP_STRING([--enable-xml-docs],[build XML documentation (requires xmlto)]),enable_xml_docs=$enableval,enable_xml_docs=auto)
#xmldocs missing
-#AC_ARG_ENABLE(doxygen-docs, AS_HELP_STRING([--enable-doxygen-docs],[build DOXYGEN documentation (requires Doxygen)]),enable_doxygen_docs=$enableval,enable_doxygen_docs=auto)
-if(DOXYGEN)
- OPTION(DBUS_ENABLE_DOXYGEN_DOCS "build DOXYGEN documentation (requires Doxygen)" ON)
-endif(DOXYGEN)
-
#AC_ARG_ENABLE(gcov, AS_HELP_STRING([--enable-gcov],[compile with coverage profiling instrumentation (gcc only)]),enable_gcov=$enableval,enable_gcov=no)
OPTION(DBUS_GCOV_ENABLED "compile with coverage profiling instrumentation (gcc only)" OFF)
if(DBUS_GCOV_ENABLED)
@@ -450,6 +445,7 @@ if (DBUS_BUILD_TESTS)
add_subdirectory( test )
endif (DBUS_BUILD_TESTS)
add_subdirectory( tools )
+add_subdirectory( doc )
OPTION(DBUS_INSTALL_SYSTEM_LIBS "install required system libraries" OFF)