summaryrefslogtreecommitdiffstats
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2007-06-14 07:56:47 +0000
committerRalf Habacker <ralf.habacker@freenet.de>2007-06-14 07:56:47 +0000
commite26ed1576a5f82dec72b13d1c6619f83237f6236 (patch)
tree8f72a1c29de9af99ae8c9fa8ca02366432ecd3fd /cmake/CMakeLists.txt
parent62f09b8bc6ca258a54a316b452d28f1c590d51c1 (diff)
* cmake/modules/FindKDEWIN.cmake, cmake/modules/FindKDEWIN_Packager.cmake cmake/modules/Win32Macros.cmake: new files from the kdewin32 project
* cmake/CMakeLists.txt: cleaned support for kdewin installer and win32 explorer wrapper
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt41
1 files changed, 8 insertions, 33 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 1eef28e0..3728aba0 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -11,9 +11,6 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.4.4 FATAL_ERROR)
# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/modules")
-find_package(KDEWIN_INSTALLER)
-
-
#enable building of shared library
SET(BUILD_SHARED_LIBS ON)
@@ -21,10 +18,13 @@ if (CYGWIN)
set (WIN32)
endif (CYGWIN)
-# search packages used by KDE
+# search for required packages
if (WIN32)
- find_package(GNUWIN32)
+ find_package(KDEWIN)
+ find_package(KDEWIN_Packager)
find_package(LibIconv)
+ include(Win32Macros)
+ addExplorerWrapper(${PACKAGE})
endif (WIN32)
find_package(LibXml2)
find_package(LibExpat)
@@ -538,33 +538,8 @@ if (DBUS_DISABLE_CHECKS)
endif(DBUS_DISABLE_CHECKS)
MESSAGE(" ")
-
INCLUDE(modules/CPackInstallConfig.cmake)
-if (KDEWIN_INSTALLER_FOUND)
- if (MSVC)
- add_custom_target(kdewinpackage
- COMMAND ${KDEWIN_PACKAGER}
- -name dbus
- -root ${CMAKE_INSTALL_PREFIX}
- -srcroot ${CMAKE_SOURCE_DIR}/..
- -version ${VERSION}
- -notes "ipc service"
- -type msvc
- -strip
- -complete
- )
- else (MSVC)
- add_custom_target(kdewinpackage
- COMMAND ${KDEWIN_PACKAGER}
- -name dbus
- -root ${CMAKE_INSTALL_PREFIX}
- -srcroot ${CMAKE_SOURCE_DIR}/..
- -version ${VERSION}
- -notes "ipc service"
- -strip
- -type mingw
- -complete
- )
- endif (MSVC)
-endif (KDEWIN_INSTALLER_FOUND)
+if (KDEWIN_PACKAGER_FOUND)
+ KDEWIN_PACKAGER(${PACKAGE} ${VERSION} "ipc library" "")
+endif (KDEWIN_PACKAGER_FOUND)