summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-04-05 00:37:17 +0000
committerHavoc Pennington <hp@redhat.com>2003-04-05 00:37:17 +0000
commit03b9ca6d4ecf2577958530b8390d675c73a58825 (patch)
treebe0569a447ef9acaf5a0004fb9bfe1a2022c9eb1 /configure.in
parent45d1479fad0fb55f1775c394e696643dad3e8e4d (diff)
2003-04-04 Havoc Pennington <hp@redhat.com>
* dbus/dbus-spawn.c, dbus/dbus-spawn.h: Change dbus_spawn to return a "babysitter" object that is used to monitor the status of the spawned process and reap it when required. * test/test-segfault.c, test/test-exit.c, test/test-sleep-forever.c: binaries that do various lame things, used in the test suite. * dbus/dbus-sysdeps.c: kill _dbus_errno_to_string()
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 076b74c3..0238282e 100644
--- a/configure.in
+++ b/configure.in
@@ -406,11 +406,18 @@ AM_CONDITIONAL(DBUS_INIT_SCRIPTS_RED_HAT, test x$with_init_scripts = xredhat)
#### Tell tests where to find certain stuff in builddir
ABSOLUTE_TOP_BUILDDIR=`cd ${ac_top_builddir}. && pwd`
-TEST_SERVICE_BINARY=${ABSOLUTE_TOP_BUILDDIR}/test/test-service
-AC_SUBST(TEST_SERVICE_BINARY)
+AC_DEFUN(TEST_PATH, [
+TEST_$1=${ABSOLUTE_TOP_BUILDDIR}/test/$2
+AC_DEFINE_UNQUOTED(TEST_$1, "$TEST_$1",
+ [Full path to test file test/$2 in builddir])
+AC_SUBST(TEST_$1)
+])
-TEST_SERVICE_DIR=${ABSOLUTE_TOP_BUILDDIR}/test/data/valid-service-files
-AC_SUBST(TEST_SERVICE_DIR)
+TEST_PATH(SERVICE_DIR, data/valid-service-files)
+TEST_PATH(SERVICE_BINARY, test-service)
+TEST_PATH(EXIT_BINARY, test-exit)
+TEST_PATH(SEGFAULT_BINARY, test-segfault)
+TEST_PATH(SLEEP_FOREVER_BINARY, test-sleep-forever)
AC_OUTPUT([
Doxyfile