summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-08-25 19:50:16 +0000
committerJohn (J5) Palmieri <johnp@redhat.com>2006-08-25 19:50:16 +0000
commit163f42a8b14491ea6f70a20a8d93f580d43f6c40 (patch)
tree966a3e95e0d84c8d239ae69c75f4665da3f31207 /configure.in
parent8f9f3deb90b5283c46a3cb992c1be2d053c942c5 (diff)
* configure.in, dbus/Makefile.am, test/name-test/run-test.sh,
test/name-test/Makefile.am: Fixed some issues with getting get dbus to build with builddir != srcdir (Taken from a patch by Bernard Leak <bernard at brenda-arkle dot demon dot co dot uk>)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5a246362..9b7fe59a 100644
--- a/configure.in
+++ b/configure.in
@@ -1002,10 +1002,10 @@ AC_SUBST(DBUS_DAEMONDIR)
AC_DEFINE_UNQUOTED(DBUS_DAEMONDIR,"$DBUS_DAEMONDIR", [Directory for installing the DBUS daemon])
#### Tell tests where to find certain stuff in builddir
-ABSOLUTE_TOP_BUILDDIR=`cd ${ac_top_builddir}. && pwd`
+DBUS_PWD=`pwd`
AC_DEFUN([TEST_PATH], [
-TEST_$1=${ABSOLUTE_TOP_BUILDDIR}/test/$2
+TEST_$1=${DBUS_PWD}/test/$2
AC_DEFINE_UNQUOTED(TEST_$1, "$TEST_$1",
[Full path to test file test/$2 in builddir])
AC_SUBST(TEST_$1)
@@ -1017,7 +1017,6 @@ TEST_PATH(SHELL_SERVICE_BINARY, test-shell-service)
TEST_PATH(EXIT_BINARY, test-exit)
TEST_PATH(SEGFAULT_BINARY, test-segfault)
TEST_PATH(SLEEP_FOREVER_BINARY, test-sleep-forever)
-AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
#### Find socket directories
if ! test -z "$TMPDIR" ; then