summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-10-11 09:57:48 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-10-11 09:57:48 +0100
commit176738f0f0f57de3f4c8553a411b26b171fdd117 (patch)
treeed98d6dd258fc0e65ab2bdff2a335b91910ae330 /configure.in
parent077fb290c57ee937330b22b2ae794fc9967d4722 (diff)
Fix detection of i486 atomic ops.
Previously, the attempts to determine support at compile-time on Darwin were causing the i486 atomic ops to be used on *all* i386 or x86-64 GCC builds (AH_VERBATIM can't be conditionalized like we were trying to).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 7 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 4ed2e1c0..c9331158 100644
--- a/configure.in
+++ b/configure.in
@@ -536,7 +536,7 @@ fi
#### Atomic integers (checks by Sebastian Wilhelmi for GLib)
AC_MSG_CHECKING([whether to use inline assembler routines for atomic integers])
-have_atomic_inc=no
+have_atomic_inc_cond=0
if test x"$GCC" = xyes; then
if test "x$enable_ansi" = "xyes"; then
AC_MSG_RESULT([no])
@@ -551,18 +551,13 @@ if test x"$GCC" = xyes; then
AC_MSG_RESULT([darwin])
# check at compile-time, so that it is possible to build universal
# (with multiple architectures at once on the compile line)
- AH_VERBATIM([DBUS_USE_ATOMIC_INT_486_DARWIN], [
- #if (defined(__i386__) || defined(__x86_64__))
- # define DBUS_USE_ATOMIC_INT_486 1
- #endif
- ])
+ have_atomic_inc_cond="(defined(__i386__) || defined(__x86_64__))"
;;
*)
AC_MSG_RESULT([i486])
- AC_DEFINE_UNQUOTED(DBUS_USE_ATOMIC_INT_486, 1, [Use atomic integer implementation for 486])
+ have_atomic_inc_cond=1
;;
esac
- have_atomic_inc=yes
;;
*)
AC_MSG_RESULT([no])
@@ -570,20 +565,10 @@ if test x"$GCC" = xyes; then
esac
fi
fi
-if test x$have_atomic_inc = xyes ; then
- case $host_os in
- darwin*)
- AH_VERBATIM([DBUS_HAVE_ATOMIC_INT_DARWIN], [
- #if (defined(__i386__) || defined(__x86_64__))
- # define DBUS_HAVE_ATOMIC_INT 1
- #endif
- ])
- ;;
- *)
- AC_DEFINE_UNQUOTED(DBUS_HAVE_ATOMIC_INT, 1, [Some atomic integer implementation present])
- ;;
- esac
-fi
+AC_DEFINE_UNQUOTED([DBUS_USE_ATOMIC_INT_486_COND], ["$have_atomic_inc_cond"],
+ [Always defined; expands to 1 if we should use atomic integer implementation for 486, else 0])
+AC_DEFINE_UNQUOTED(DBUS_HAVE_ATOMIC_INT_COND, ["$have_atomic_inc_cond"],
+ [Always defined; expands to 1 if we have an atomic integer implementation, else 0])
#### Various functions
AC_CHECK_LIB(socket,socket)