summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-03-31 23:19:19 +0000
committerHavoc Pennington <hp@redhat.com>2003-03-31 23:19:19 +0000
commit18c470cd2c7245f33f5d924d23972e95e3d347a0 (patch)
tree86f597a9d40e81142f85d3b56f07889060877cd5 /configure.in
parentfa05de9230d62e7c427b5313796fc6ccd4d0ff60 (diff)
2003-03-31 Havoc Pennington <hp@redhat.com>
* bus/Makefile.am (install-data-hook): create /var/run/dbus * bus/messagebus.in: add init script for Red Hat /etc/init.d * configure.in: add support for specifying a style of init script to install
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 31 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3714ca16..46e18707 100644
--- a/configure.in
+++ b/configure.in
@@ -29,9 +29,10 @@ AC_ARG_ENABLE(tests, [ --enable-tests enable unit test code],enable_tests=$
AC_ARG_ENABLE(ansi, [ --enable-ansi enable -ansi -pedantic gcc flags],enable_ansi=$enableval,enable_ansi=no)
AC_ARG_ENABLE(verbose-mode, [ --enable-verbose-mode support verbose debug mode],enable_verbose_mode=$enableval,enable_verbose_mode=yes)
AC_ARG_ENABLE(asserts, [ --enable-asserts include assertion checks],enable_asserts=$enableval,enable_asserts=yes)
-AC_ARG_ENABLE(gcov, [ --enable-gcov compile with coverage profiling instrumentation (gcc only)],enable_gcov=$enableval,enable_gcov=no)
+AC_ARG_ENABLE(gcov, [ --enable-gcov compile with coverage profiling instrumentation (gcc only)],enable_gcov=$enableval,enable_gcov=no)
-AC_ARG_WITH(xml, [ --with-xml=[libxml/expat] XML library to use])
+AC_ARG_WITH(xml, [ --with-xml=[libxml/expat] XML library to use])
+AC_ARG_WITH(init-scripts, [ --with-init-scripts=[redhat] Style of init scripts to install])
dnl DBUS_BUILD_TESTS controls unit tests built in to .c files
dnl and also some stuff in the test/ subdir
@@ -376,10 +377,37 @@ EXPANDED_LOCALSTATEDIR=`eval echo $LOCALSTATEDIR_TMP`
prefix=$old_prefix
AC_SUBST(EXPANDED_LOCALSTATEDIR)
+SYSCONFDIR_TMP="$sysconfdir"
+old_prefix=$prefix
+prefix=$REAL_PREFIX
+EXPANDED_SYSCONFDIR=`eval echo $SYSCONFDIR_TMP`
+prefix=$old_prefix
+AC_SUBST(EXPANDED_SYSCONFDIR)
+
+BINDIR_TMP="$bindir"
+old_prefix=$prefix
+prefix=$REAL_PREFIX
+EXPANDED_BINDIR=`eval echo $BINDIR_TMP`
+prefix=$old_prefix
+AC_SUBST(EXPANDED_BINDIR)
+
+#### Sort out init scripts
+
+if test x$with_init_scripts = x; then
+ if test -f /etc/redhat-release || test -f $EXPANDED_SYSCONFDIR/redhat-release ; then
+ with_init_scripts=redhat
+ else
+ with_init_scripts=none
+ fi
+fi
+
+AM_CONDITIONAL(DBUS_INIT_SCRIPTS_RED_HAT, test x$with_init_scripts = xredhat)
+
AC_OUTPUT([
Doxyfile
bus/system.conf
bus/session.conf
+bus/messagebus
Makefile
dbus/Makefile
glib/Makefile
@@ -410,6 +438,7 @@ echo "
Building GLib bindings: ${have_glib}
Using XML parser: ${with_xml}
System bus socket: ${EXPANDED_LOCALSTATEDIR}/${DBUS_SYSTEM_SOCKET}
+ Init scripts style: ${with_init_scripts}
"
if test x$enable_tests = xyes; then