summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-04-22 03:20:27 +0200
committerLennart Poettering <lennart@poettering.net>2009-05-20 01:36:27 +0200
commit4c4db7f9da1aa29c264a9f9d7d9fb1d774e28ee1 (patch)
tree7b54a00000498005f0d0c19b5d9c91814658cb08 /configure.in
parent64c63db21ebdc81f4f830d0d9f1957259cff8f24 (diff)
sysdeps-unix: add basic IO primitives for unix fd passing
This introduces three new functions: _dbus_read_socket_with_unix_fds _dbus_write_socket_with_unix_fds _dbus_read_socket_with_unix_fds_two These work exactly like their counterpart sans 'with_unix_fds' except that they also send/recieve file descriptors along with the actual payload data.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 88d2164c..0732adcd 100644
--- a/configure.in
+++ b/configure.in
@@ -1094,6 +1094,16 @@ else
AC_MSG_RESULT(no)
fi
+# Check for SCM_RIGHTS
+AC_MSG_CHECKING([for SCM_RIGHTS])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#include <sys/socket.h>
+#include <sys/un.h>
+static int x = SCM_RIGHTS;
+]], [[]])],
+[ AC_MSG_RESULT([supported])
+ AC_DEFINE([HAVE_UNIX_FD_PASSING], [1], [Supports sending UNIX file descriptors]) ],
+[ AC_MSG_RESULT([not supported]) ])
#### Set up final flags
DBUS_CLIENT_CFLAGS=