summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2008-12-19 20:02:14 -0500
committerColin Walters <walters@verbum.org>2009-01-06 17:43:18 -0500
commit6413acafefb307021d91ddaf21c4b0489ebf3bff (patch)
treefbdbe966ed7175f8e9ac6ec6bd6a28797914f67e /configure.in
parent4e4f0de8cc8c3127641013fd833349dab34b676b (diff)
Enable -Werror by default with --enable-maintainer-mode, and change warnings
Important compiler warnings were being lost in the noise from warnings we know about but aren't problems, and moreover made using -Werror difficult. Now we expect *all* developers and testers to be using -Werror.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 42 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 54025b36..b649f5ef 100644
--- a/configure.in
+++ b/configure.in
@@ -175,6 +175,12 @@ ld_supports_flag() {
fi
}
+if test x$USE_MAINTAINER_MODE = xyes; then
+ if cc_supports_flag "-Werror"; then
+ CFLAGS="$CFLAGS -Werror"
+ fi
+fi
+
if test "x$GCC" = "xyes"; then
changequote(,)dnl
case " $CFLAGS " in
@@ -221,11 +227,6 @@ if test "x$GCC" = "xyes"; then
esac
case " $CFLAGS " in
- *[\ \ ]-Wsign-compare[\ \ ]*) ;;
- *) CFLAGS="$CFLAGS -Wsign-compare" ;;
- esac
-
- case " $CFLAGS " in
*[\ \ ]-Wdeclaration-after-statement[\ \ ]*) ;;
*) if cc_supports_flag -Wdeclaration-after-statement; then
CFLAGS="$CFLAGS -Wdeclaration-after-statement"
@@ -264,6 +265,41 @@ if test "x$GCC" = "xyes"; then
fi
;;
esac
+
+ ### Disabled warnings, and compiler flag overrides
+
+ # Let's just ignore unused for now
+ case " $CFLAGS " in
+ *[\ \ ]-Wno-unused[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wno-unused" ;;
+ esac
+
+ # This group is for warnings we currently don't pass.
+ # We would like to, however. Please fix.
+
+ # http://bugs.freedesktop.org/show_bug.cgi?id=17433
+ case " $CFLAGS " in
+ *[\ \ ]-Wno-sign-compare[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wno-sign-compare" ;;
+ esac
+ case " $CFLAGS " in
+ *[\ \ ]-Wno-pointer-sign[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wno-pointer-sign" ;;
+ esac
+
+ # http://bugs.freedesktop.org/show_bug.cgi?id=19195
+ case " $CFLAGS " in
+ *[\ \ ]-Wno-format[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wno-format" ;;
+ esac
+
+ # This one is special - it's not a warning override.
+ # http://bugs.freedesktop.org/show_bug.cgi?id=10599
+ case " $CFLAGS " in
+ *[\ \ ]-fno-strict-aliasing[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -fno-strict-aliasing" ;;
+ esac
+ ### End disabled warnings
if test "x$enable_ansi" = "xyes"; then
case " $CFLAGS " in
@@ -284,7 +320,7 @@ if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-pedantic[\ \ ]*) ;;
*) CFLAGS="$CFLAGS -pedantic" ;;
- esac
+ esac
fi
if test x$enable_gcov = xyes; then
case " $CFLAGS " in