summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMarc Mutz <marc@kdab.net>2009-01-07 12:46:53 +0100
committerThiago Macieira <thiago@kde.org>2009-05-13 15:50:52 +0200
commit6eddb6e1229b617ad44c8d61107983229dc7d589 (patch)
tree1161ec2069d18181c37efcecb3d4d832a9997a46 /configure.in
parentf719d454329a1a54ff2d569feaf10ceee7cead50 (diff)
configure.in: fail abstract socket test gracefully when cross-compiling
* configure.in: only run AC_CACHE_CHECK if enable_abstract_sockets=auto * configure.in: warn that, when cross-compiling, we're unable to detect abstract sockets availability automatically Signed-off-by: Thiago Macieira <thiago@kde.org>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index fd972b49..9e047eae 100644
--- a/configure.in
+++ b/configure.in
@@ -814,8 +814,9 @@ AC_CHECK_FUNCS(getpeerucred getpeereid)
#### Abstract sockets
-if ! test x$enable_abstract_sockets = xno; then
+if test x$enable_abstract_sockets = xauto; then
AC_LANG_PUSH(C)
+warn_on_xcompile=no
AC_CACHE_CHECK([abstract socket namespace],
ac_cv_have_abstract_sockets,
[AC_RUN_IFELSE([AC_LANG_PROGRAM(
@@ -855,8 +856,15 @@ AC_CACHE_CHECK([abstract socket namespace],
exit (0);
]])],
[ac_cv_have_abstract_sockets=yes],
- [ac_cv_have_abstract_sockets=no]
+ [ac_cv_have_abstract_sockets=no],
+ [
+ ac_cv_have_abstract_sockets=no
+ warn_on_xcompile=yes
+ ]
)])
+if test x$warn_on_xcompile = xyes ; then
+ AC_MSG_WARN([Cannot check for abstract sockets when cross-compiling, please use --enable-abstract-sockets])
+fi
AC_LANG_POP(C)
fi